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irectory 

2    Installation and Activation 

2.1   Installation 
1. Start the PC with Administrator rights. 
2. Insert the installation CD and via autorun the language selection screen will show up. 

If Autorun does not work, please run the setup.exe in the following d
\...\Modele_CD_Trotec_2010R1\Setup_Alphacam_2010 
 

3. Select the required language 

 
 
4. Wait while the setup is configured and prepared 
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5. Accept the License Agreement 
 

 
 
 
6. Wait while the setup is finished 
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7. Finish the Installation with a restart of the PC 
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2.2   Activation 
Remove an eventually installed old Dongle and have your 6x4-digit servercode ready from your 
installation CD booklet. 
 
Start TroCAM with administrator rights and the License Activation window will show up. 

 
 
Assure that the “locking criteria for this machine” is “Keyless”. That means, the license will be linked 
to the Hardware. If the “locking criteria” is different, it means that a Dongle is plugged. In that case, 
close the Window, remove the Dongle and restart the activation. 
 
Enter the Servercode which you received with your Installation CD. 
 
If internet is available, the activation is finished with click on „Submit On-line“ and you can work with 
TroCAM. 
Without internet connection click on „No Internet Available“ and you get a text file with further 
information and a link. Follow the link to the “Planit” homepage on a PC with internet connection 
and enter the lock code of your machine and the Server Code. You get a .one file which you should 
transfer to the Desktop of the TroCAM-PC. With double-click on the .one file the activation is 
finished and you can work with TroCAM. 
 
Perform the first startup of TroCAM with administrator rights. 
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3    TroCAM Main Window 
 
 Menu bar Toolbar Drawing area 
 

 
 
  Project manager Command line  Status bar 
 
You can customise the appearance of the main window. You can add or remove tools on the 
toolbar. You can change the positions of the tool bars, command line and project manager. 
You can change the background colour of the drawing area. 
 
Via right mouse click on a toolbar a list of all active and inactive toolbars is shown. 

 
Via mouse click on the symbol with four dots the toolbar can be moved. Toolbars within the 
drawing area can be caught and moved via left mouse click on the header bar of the toolbar. 

 
Via right mouse click on the drawing area a context menu is shown. 
 
Via the tool bar “View” different display modes can be selected. 
 

 
The same buttons can be found in the menu bar. 
 

 
With the wheel on a mouse the zoom function is activated. Focus is defined by the cursor position. 
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4    Configurations 

4.1   Selecting the Postprocessor 
During first program start the selection window for the postprocessor opens automatically. Please 
select PPTrocam.amb. 
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4.2   Configuring the toolbar  
Each toolbar has a small black arrow. Clicking on this arrow brings up the Add or Remove 
Buttons menu and a choice of toolbars. By checking or un-checking the buttons, you can select 
which toolbars are displayed. 
 

 
 
Via Customize the buttons can be edited. The buttons can be copied and changed. The Symbol 
can be changed or set to text view. 
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4.3   Configuring the general settings 
In the menu bar File, select Configuration  General. 

 
“Settings” 
“Number of undos allowed” defines the number of 
entries that can be undone. 
 
“Default font” specifies the font for all text editing. 
 
“Auto-Save Interval” defines the intervals of automatic 
saving of the data. 
 
The most recently opened files are listed in the menu 
File. 
 
Display preview for drawing files: 
Add preview: 
In “Licomdir” select the directories for which preview 
should be active. 
Remove preview: 
In “Licomdir” select the directories for which preview 
should be deactivated. 
 
“Prompt Before Save”: when active, user is asked if 
the actual graphics should be overwritten. 
 
 

 
 
“Geometry” 
The processing direction – CW or CCW – and start point for circles can be preset here.  
 
“Line Widths” 
Use this to set the line width for standard lines when printing out.  
 
“Machining” 
The default values for relieve level and safety level are entered here. 
 
“Colours” 
The colour adjustments for lines and planes can be made here. The settings can be saved. Reset 
returns to the original colours. 
 
“Window layout” 
Open and save different layouts to adjust the layout of the TroCAM screen to your needs. 
 
“Dynamic View” 
Adjust the speed settings for mouse and keyboard move-commands. 
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4.4   Configuring the system folders 
In the file menu bar, select configuration / system folder. 
 

 
 
 
Here the TroCAM system paths can be changed.  
 
Programs must always be saved in the Licomdir 
directory. 
Additional directories and subdirectories can be 
created in the Licomdir directory. 
 
 
 
 
 
 

4.5   Configuring the background colour for the drawing area  
In the View menu bar, select Background Colours. 
 

 
The background colour can be set using this 
table. 
 
 
 
 
 
 
 
 
 
 
 

 

4.6   Configuring the ruler for the drawing area  
 
In the View menu bar, select Set Limits. 
First the bottom left corner will be defined, and after clicking on OK, the upper right corner. 
In the View menu bar, select Zoom Limits. 
Scaling will be adapted to the new ruler. 
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5    CAD Geometry 
 
Entries Enter coordinates via the command line or object snaps. 

 
 

5.1   Simple 2D-Geometries – lines, arcs, circles, rectangles 
 

 
Line: In the Geometry menu bar, select Line. 
 In the Command Line, you will see the prompt: 

 
 

 
 
Enter coordinates X and Y, and confirm. Confirm with OK or Enter. 
Next the Command Line will ask for the end point (“LINE To”). 
 

 
 
In TroCAM, all commands remain active until a new command is selected or the active 
command is ended with ESC. The previous command can be reactivated with the space bar. 
 
Instead of the ESC button, the right mouse button can be used.  
 
F1 identifies the window as unknown. 
As a result, the window below is opened to allow the direction of angle to be entered.  
 

 
 

 
Arc:  In the menu bar Geometry, select Arcs  2 points and  radius. 
 In the Command Line, you will see the prompt: 

 

 
 
Arcs are always constructed counter clockwise. The starting point must be selected accordingly. 
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You will then be asked for the end point in the Command Line. 
 

 
 
You will be asked for the radius in the Command Line. 
 

 
 

 
Circle:  In the menu bar Geometry, select Circles  Centre and Diameter. 
  In the Command Line, you will see the prompt: 

 

 
 
 

Once the diameter has been defined, you will be asked for the circle centre. 
 

 
 

 

Rectangle: In the menu bar Geometry, select Rectangle. 
In the Command Line, you will see the prompt: 

 

 
 
Once the coordinates of the first corner have been confirmed, you will be asked in the Command 
Line for the second corner, diagonally opposite the first.  
 

 
 

 
Construction:  In the menu bar Geometry, select Construction. 
 

When Construction is active, the geometries are drawn in purple rather than green. Construction 
geometries cannot be edited. They simply serve as guides. 
 

5.2   Special 2D-Geometries 
 
In the menu bar Geometry select Special 2D Geometries 
 

 
Polygon 

 
Slot 

 
Ellipse 

 
Equi-Spaced Holes 

 
Bolt Hole Circle 

 
Enclosing Rectangle 

 
Involute Curve   
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6    Utils 
 
The Utils menu contains a lot of useful auxiliary functions for determining coordinates. 

 
 

6.1   Object Snaps 
 
Object snaps can only be used in combination with another command. Object snaps do not remain 
active once they have been executed. In this respect, object snaps are an exception in TroCAM. 
They have to be reactivated each time except Ctrl has been pressed during activation. Use the 
function keys and buttons described below to activate the object snaps. 
  
In the menu bar Geometry, select Object Snaps. 
 

 
Select end points of lines and arcs 

Select middle points of lines and arc 

Select centre of lines and arcs 

Select intersections of lines and arcs 

Tangential intersection of an arc 

Line perpendicular to a line or arc 

Line parallel to a line 

Quadrants of a circle 

 
 
After an object snap has been selected, the mouse pointer changes to a representation of the 
active object snap. 
 
A prompt in the Command Line asks you to select a Line or an Arc. 
 
When Auto Snap is active, the mouse pointer automatically jumps to the next possible object snap.  
 
 

Auto Snap: In the Utils menu bar, select Auto Snap. 
The function is displayed in the Status Line when it is active. 

 
 
 
Auto Snap can also be activated and deactivated using the Function Key F2. 
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Grid Ortho: In the Utils menu bar, select Grid / Ortho. 
   

 
 
A rectangular grid is laid over the entire screen.  
When snap to grid is active (SNAP), the mouse 
pointer automatically jumps to the grid nodes. The 
distance between the nodes is defined in X and Y. 
 
 
 
 
 
 

 
The functions Orthogonal (ORTHO) and Snap to Grid (SNAP) are displayed in the status line when 
they are active. 

 
 
Ortho mode can be activated and deactivated either using this button or with F3. 
 
 
Snap mode can be activated and deactivated either using this button or with F5. 
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6.2   Calculating coordinates and mass sizes 
The following auxiliary functions are available for checking X, Y, Z coordinates, angles, lengths and 
radii. 
 

Distance, Angle: In the Utils menu bar, select Distance / Angle. 
   In the Command Line, you will see the prompt: 

 

 
 
The first point is defined by entering the coordinates or by using object snap.  
The second point is defined in the same way.  

 
 
 
Angle and Absolute Distance are displayed from the 
first to the second point. 
Distance in X, Y and Z is measured from the first to the 
second point. 
 
 
 
 
 

 
Coordinates:  In the Utils menu bar, select Report Coordinates 
   In the Command Line, you will see the prompt: 

 

 
  
The point for which coordinates are required can be selected using Object Snap. 
The global coordinates of this point are displayed in the Command Line. 

 
Radius of: In the Utils menu bar, select Radius of. 
  In the Command Line, you will see the prompt: 

 

 
 
When you click on the arc with the mouse pointer, the value of the radius is displayed in the 
command line. 

 

6.3   Special functions 
In the Utils menu bar, select Special Functions. 
 
 Compress Geometries 

 
Generate Border Contours 
 

 Delete hidden Contours  Add-Ins 
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7    Editing 
 

 

7.1   Break, Join 
 
Break  In the Edit menu bar, select Break, Join  Break. 
 

 
 
 
You next have to decide whether Geometries or Tool 
paths will be broken. 
 
Select Individual to break a single geometry at a specific 
point. 
Use Cutting Geometry causes two geometries to cut each 
other, one geometry serving as the borderline on whose 
intersection points the other geometry is broken.  
 
 

 
Individual 
In the Command Line, you will see the prompt: 

 
 
Define the point by using object snap or by entering the coordinates. 
 
Use Cutting Geometry 
In the Command Line, you will see the prompt: 

 
 
The cutting geometry is the geometry that acts as a borderline.  
Select the geometries that act as borderlines and end with ESC. 
In the Command Line, you will see the prompt: 

 
 
Select the geometries to be broken up and end with ESC. 
A white cross will appear at the intersection points where the geometry has been broken open. 

 
Break everything In the Edit menu bar, select Break, Join  Break open contour pass. 
   In the Command Line, you will see the prompt: 

 
 
After ending with ESC, the selected geometries are broken into their individual elements. 
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Join  In the Edit menu bar, select Break, Join  Join. 
  In the Command Line, you will see the prompt: 

 
 
Select the geometries that are to be joined and end with ESC. 
 

7.2   Erase 
 
Undo In the Edit menu bar, select Undo: Entry. 
 

A window will appear with a list of the functions to be undone, and must be confirmed with OK or 
Cancel. 
The number of actions to be undone can be defined in the configuration. 
 

 
Erase  In the Edit menu bar, select Erase. 
  In the Command Line, you will see the prompt: 

 

 
 
Use the mouse to click on the geometries to be erased, and end with ESC. A window will appear 
with the number of geometries to be erased, and must be confirmed with OK or Cancel. 
Selecting All will erase everything. With Previous, the geometries that were selected previously are 
reselected. 
 
 

7.3   Move, Copy, Offset 
 
Move  In the Edit menu bar, select Move, Copy  Move. 
  In the Command Line, you will see the prompt: 

 

 
 

Select the geometries to be offset and confirm with ESC. 
In the Command Line, you will see the prompt: 
 

 
 

Define the basis point using object snap or by entering the coordinates. 
In the Command Line, you will see the prompt: 
 

 
 

Enter the coordinates of the offset point or mark the new position using object snap. 
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In TroCAM, all functions remain active until a new function is selected or the active function is 
ended with ESC. 
 

 
Copy  In the Edit menu bar, select Move, Copy  Copy. 
 

The other steps are the same as for Move, except that here a copy of the geometries is made.  
 
Offset In the Edit menu bar, select Break, Join  Offset. 
   

 
With Offset, geometry is offset by a given Distance. The original 
is preserved. 
 
Individual elements, complete geometries or surfaces can be 
offset.  
 
Individual elements are recreated as construction elements with 
Offset.  
 
 
 

 
Lines/arcs: 
In the Command Line, you will see the prompt: 
 

 
 
Select line or arc to be offset. Only one element can be selected. 

In the Command Line, you will see the prompt: 

 
 

Click on the side on which the element is to be offset. 
 
Geometry: 
In the Command Line, you will see the prompt: 

 
 

Select the geometry to be offset. Only one geometry can be selected at a time. 

In the Command Line, you will see the prompt: 

 
 

 
Click on the side on which the geometry is to be offset with the mouse, or define the side by 
entering its coordinates. 
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7.4   Rotate, Mirror 
 
Rotate  In the Edit menu bar, select Move, Copy  Rotate. 
  In the Command Line, you will see the prompt:  

 

 
 
Select the geometries to be rotated and confirm with ESC. 
In the Command Line, you will see the prompt: 
 

 
 
Enter the coordinates for the centre of rotation 
In the Command Line, you will see the prompt: 
 

 
 
The angle for clockwise rotation must be preceded by a minus sign. 
 

 
Mirror   In the Edit menu bar, select Move, Copy  Mirror 
   In the Command Line, you will see the prompt: 

 

 
 
Select the geometries to be mirrored and confirm with ESC. 
In the Command Line, you will see the prompt: 
 

 
 
With Mirror, an axis must be defined around which the geometries are mirrored. Once you have 
defined the first point, you will be prompted to enter the second point: 
 

 
 
A window will then appear asking if the original should be kept. Selecting yes means that a mirror-
image copy of the original is created. Selecting No means that the original is flipped. In both cases 
the mirror image is rotated around the axis of reflection. 
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7.5   Change Element Type 
 
Change In the Edit menu bar, select Change Element Type. 
 

 
This table allows an existing element to be changed 
into another element. For instance, a construction 
element can be changed into geometry.  
 
Elements can be moved from the original layer into 
the active layer. 
 
Text as Fonts can be changed to geometry etc. 
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8    Import CAD file 
 
Drawings from other CAD systems in DXF and DWG formats can be imported into TroCAM. 
 
DXF is a widely used, standardised file format for digitised 2D drawings. 
 
DWG is the format used by AutoCAD. 
 

8.1   Import files 
 
In the File menu bar, select Input CAD... 
 

 
 
 

 
 
 
 
Text is not transferred as geometry and a font 
must be defined for it. 
 
With Join Elements, unwanted line interruptions 
can be avoided with the appropriate tolerance 
selection.  
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8.2   Convert splines to polyarcs 
Any splines in the drawing will be brown lines instead of the usual green for polyarcs. If there are 
splines, they must be converted to polyarcs before they can be toolpathed. 
 
In the Geometry menu bar, select Splines  Convert Spline to Line/Arc 
 

 
 
 
Change the tolerance to 0.001 and click OK. 
 
Click on All at the Command line and confirm with Finish or ESC. 
 
Check if the transformation was OK 
 
If not, reduce the tolerance to e.g. 0.01 or 0.001 instead of 0.1. 
If the outcome is fine, delete the splines. 
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9    Laser Functions and TroCAM Bar 
The TroCAM functions can be found as button bar and in the menu bar. 
 
Operation via tool bar  or menu bar 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Find a description of the different functions below. 
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9.1   Create and select materials in the material database 
TroCAM offers a database to save materials. To Create and Save Materials proceed as follows: 
 

Select Materials  In the TroCAM menu bar, select Select Materials. 
 

 
 
 
 
 
 
 
 
 
 
 
To create a new material group click on NEW without 
selecting an existing material group and click on NEW in 
the material group window and choose a name. 
 
To create a new material select the desired material 
group, click on NEW and enter the whished settings in the 
right area.  Click on “safe” when finished. 
 
A Folder for each material group and a file for each 
material will be created. 
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To select a material, mark the material group and material name and click on “Select”. 
 

 
 

9.2   Import and Export Material from Excel 

 Input Material In the TroCAM menu bar, select Input Material from Excel. 
 
Browse to your Excel file with Material data and import it. The format of the Excel file has to be like 
the one below: 
 

 
 
 

 Output Material In the TroCAM menu bar, select Output Material to Excel 
 
 
An Excel file will be created with name of material group and material name and the according 
parameters as the table above. 
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9.3   Tool directions 
 Ghost Tools  In the View menu bar, select Ghost Tools 

 
Arrows will show up at each tool path showing in which direction and on which side of the line the 
tool (laser beam) will pass. 
 
 

Tool Directions In the TroCAM menu bar, select Tool Directions 
 
In the Tool Directions Window you can choose different settings for Open Geometries and Closed 
Geometries. 
 

 
 
 
Open Geometries have different Start- and 
Endpoints. 
 
 
 
 
 
 
 
On closed geometries the coordinate of Start- and 
Endpoint is the same. 
 
 
 
 
 
 
 
Set Start Point 
When activated, the start point on a closed 
geometry can be defined. On open geometries this 
checkbox has to be deactivated. 
 
 

 
 

 Tool Directions auto In the TroCAM menu bar, select Tool Directions auto 
 
The Software will automatically calculate the tool paths. When using this option for more 
complicated tool paths, always double check the paths. If necessary make manual changes via 
previous Tool Directions interface. 
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9.4   Create toolpaths 

 Cutting In the TroCAM menu bar, select Cutting 
 
In this Machining interface you can select the settings for cutting geometries. You might select 
another material or adjust the settings of the material directly in this window. The changes in this 
window will not be saved in the material database but will only be working for the actual jobs. 
 

 
 
 
 
 
All:  All Geometries will be processed with 

the parameters set below 
Selected: The geometries have to be selected  

manually for procession. 
Partial:  Only parts of a geometry will be 

processed. 
 
 
Loop:  The cutting quality on the corners will 

be improved. 
 
 
Editable parameters of the chosen material. 
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 Poach  In the TroCAM menu bar, select Poach 
 
In this Machining interface you can select the settings for filling (fillet) geometries. You might select 
another material or adjust the settings of the material directly in this window. The changes in this 
window will not be saved in the material database but will only be working for the actual jobs. 
 
The setting of pitch and angle might need some experience and tests. 
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9.5   Lead In/Out 
 

 Lead In/Out  In the TroCAM menu bar, select Lead In/Out 
 
The “Lead In/Out” interface will open. 
 
Choose your settings for lead-in and lead-
out separately. You can select type of the 
lead (straight line or arc) and according to 
these selections the length of the line or the 
radius and approach angle of the arc. 
 
Say OK and select the desired geometries 
or click on ALL in the command line. 
 
Click on FINISH or press ESC to confirm 
the command. 
 
 
 
 
 
 
 
 
 

9.6   Optimize cutting order (manual/auto) 
 

 Order  In the Edit menu bar, select Order 
 

 
 
Choose “Geometries” and “Auto” to do an automatic change of processing order. 
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 order manually, select “Manual” and select the single geometries in the 
e processed. 

9.7

If you want to change the
rder you want them to bo

   Edit toolpath 
 

 Edit  In the TroCAM menu bar, select Edit 
 
Mark an operation path and click on “Edit” to change the settings of machining. You may change 
the order of the paths by marking a path and clicking on the up or down arrow on the right. 

9.8   Update NC-Paths 

 
 

 

 Update NC-paths  In the TroCAM menu bar select  Update NC-Paths. 

With this function all tool paths will be adjusted to the changes of geometries. 
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9.9   Send tool path to the laser 
 
Send to machine  In the TroCAM menu bar, select Send CN to Machine 
 

 
The NC-program will be sent directly to the machine. The settings of the data transfer have to be 
done in AlphaEDIT. 

 
Choose the right machine and with it the 
right Post Processor for your machine. 
 

 IPC-Configuration 
Press this button only if you need to 
change the settings of the „Intelligent 
Path Control“. For further details please 
refer to Trotec IPC (Intelligent Path 
Control) on page 49. 
 
Coordinate 
Choose relative to process the geometry 
starting with the 0/0 of the TroCAM 
drawing area at the actual position of the 
laser head. 
 
The Home-position to drive the 
laserhead to after job end can be defined 
additionally. 
 
 

 Save NC-path – with click on this button you can save the generated paths to make them 
available in future for processing without further handling. 
 
Before you press  make sure you focused on the material and positioned the laser head on 
the desired position. 
 

 
Generate and send NC Code 
 

 
With this function the program “findLaser” will be started and the transfer-parameters are registered 
in Alphaedit. 
 

 
Resend last NC-Code 
 

 
With this function the NC-program is sent directly to the machine without activating “find laser”. 
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10    Nesting module 

10.1   TroCAM 
 
Start with drawing a “sheet” to nest the shapes to. This might be a rectangle fitting your working 
area or any other object fitting your material. 
Then draw or import your shapes to be nested. Proceed as follows 
 
Nesting: Select Nesting module from the Utils menu bar. 
 
 
 
 
 

 
 
 
Select the desired nesting method and define if you want to nest Geometries, Toolpaths or both. 
Then click on OK. 
 
In the Command Line, you will see the prompt: 

 
 
Click on the first shape to be nested. 
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Define the part parameters for the shape. 

nly 
e 

 
 
 
Number Required: Enter a number if you o
want a defined amount of shapes or choos
“Maximum possible” 
 
Rotate in intervals of: The part is rotated by the 
value given until the best position is found. 
 
Rotate through a given angle: The part is 
rotated sequentially through the given angle until 
the best position is found.  
 
Try to rotate part first: Normally the first 
part is nested in its original position. With 
this option, rotated parts are fitted first. 
 
Priority (1=highest): The parts with the 
highest priority are nested first, followed by 
the parts with lower priority e.g. 2, 3, etc. 
 

 
Select further shapes and proceed as described above until all shapes are selected and defined. 
Then click on <ESC>. 
 
 
In the Command Line, you will see the prompt: 

 
 
 
Click on the nesting sheet on the plot area. If there are several nesting sheets, nesting priority is 
established according to the order in which they are selected. Define the Sheet parameters. 
 

 
 
The prompt Select nesting sheet must be closed with ESC, once all the nesting sheets have been 
selected. 
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Define the Nesting Parameters. 

 
 
NC Code: A subroutine generates shorter NC programs. In the case of control systems with limited 
memory, a potential “drip feeding” can be avoided in this way. 

Pack to: Indicates from which side or corner nesting should begin.  

Search resolution: Defines a grid in inches, in which the parts are placed before nesting, and 
before being placed based on the parameters. The search resolution should not be greater than 
20% of the smallest dimension. A too small grid produces longer computing times without any 
significant improvement in utilisation. 

 

Special Functions: With the following options, it is important to take into account whether only 
geometries or NC paths are being nested.  

Assisted Nest: This option opens a new dialogue window in which all the parts are listed. Each 
part can be manually set on the nesting plate. Each part placed is removed from the list. 

Cut Whole Part Together: With this, each part is finished before the next part is machined. This is 
used in connection with “first drilling, then inside machining” and linear NC Code. 

Drill, then Cut Inner Paths First: All bore holes are first carried out, followed by the work inside 
the piece. 

Group Each Part Separately: Normally, parts consisting of several geometries are created as a 
group. A part that consists of a single geometry is not defined as a group. With this option, however, 
these parts are also created as groups. 

Leave Edge Gap Uncut: Normally the distance of the parts from the plate edge is equal to a 
predefined value. With this option, the tool diameter is added to the distance from the plate edge.  
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Minimise tool changes: The machining sequence is organised around the work tools in order to 
minimise tool changes.  

Order By Part: This means that identical parts are processed first, before processing the next part. 

Remove Groups: With this option, no groups are defined. Each geometry is listed individually.  

Repeat First Row/Column: Use this when nesting needs to happen in strips.  

Nest Small Parts First: When this option is not active, large parts are nested first.  

Suppress Redraw: Normally certain steps in the optimisation process are updated on screen. With 
this option, the screen is only updated at the end of optimisation.  

Try Rotated Parts First on all Parts: Normally, the first part is nested in its original position. With 
this option, rotated parts are used first. 

 

Confirm with OK to create the nesting job. 
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10.2   TroCAM Nesting Upgrade 
 

Nesting: Select Nesting module from the Utils menu bar. 
 

 
Retrieve an existing list. 

 

Create a new nesting list. 

 

 

Define and select nesting sheets 

 

Some of these functions are also available in the Project Manager under the nesting index. 

 
 

10.2.1   Defining a new nesting job 
 
 
 
 
Depending on the shape of the parts, select either free-
form or rectangular method. 
Free-form will be used for all non-rectangular parts.  
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Contour types:  
 
NC paths Only the NC paths are transferred to the nesting sheet. The geometries are 

not transferred to the nesting sheet. 
Geometries Only closed geometries are nested. 
 
NC paths and 
inner geometries The NC paths are nested together with the geometries.  
 
After confirmation, a list of files can be assembled for a nesting job (e.g. 
Licomdir\Tutorial\NestLetters\). 

 
Use Ctrl-A to select the entire list.  
 
Each part, or all selected parts, is defined with the following parameters.  

 
 
Rotate in intervals of: The part is rotated by the 
value given until the best position is found.   
 
Rotate through a given angle: The part is rotated 
sequentially through the given angle until the best 
position is found.  
 
Try to rotate part first: Normally the first part 
is nested in its original position. With this 
option, rotated parts are fitted first. 
 
Priority (1=highest): The parts with the 
highest priority are nested first, followed by the 
parts with lower priority e.g. 2, 3, etc. 
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Next the nesting parameters are defined. 
 

 
NC Code: A subroutine generates shorter NC programs. In the case of control systems with limited 
memory, a potential “drip feeding” can be avoided in this way. 

Pack to: Indicates from which side or corner nesting should begin.  

Search resolution: Defines a grid in inches, in which the parts are placed before nesting, and 
before being placed based on the parameters. The search resolution should not be greater than 
20% of the smallest dimension. Too small a grid produces longer computing times without any 
significant improvement in utilisation.  

 

Special Functions: With the following options, it is important to take into account whether only 
geometries or NC paths are being nested.  

Group Each Part Separately: Normally, parts consisting of several geometries are created as a 
group. A part that consists of a single geometry is not defined as a group. With this option, however, 
these parts are also created as groups. 

Remove Groups: With this option, no groups are defined. Each geometry is listed individually.  

Drill, then Cut Inner Paths First: All bore holes are first carried out, followed by the work inside 
the piece.  
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Cut Whole Part Together: With this, each part is finished before the next part is machined. This is 
used in connection with “first drilling, then inside machining” and linear NC Code. 

Assisted Nest: This option opens a new dialogue window in which all the parts are listed. Each 
part can be manually set on the nesting plate. Each part placed is removed from the list. 

Nest Small Parts First: When this option is not active, large parts are nested first.  

Repeat First Row/Column: Use this when nesting needs to happen in strips.  

Suppress Redraw: Normally certain steps in the optimisation process are updated on screen. With 
this option, the screen is only updated at the end of optimisation.  

Suppress Final Sort: 

Order By Part: This means that identical parts are processed first, before processing the next part. 

Try Rotated Parts First on all Parts: Normally, the first part is nested in its original position. With 
this option, rotated parts are used first. 

Minimise tool changes: The machining sequence is organised around the work tools in order to 
minimise tool changes.  

Leave Edge Gap Uncut: Normally the distance of the parts from the plate edge is equal to a 
predefined value. With this option, the tool diameter is added to the distance from the plate edge.  

 

 

Confirm with OK to create the nesting job.  
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Use a right mouse click on the nesting job name to access 
the functions for processing the entire job:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Use a right mouse click on a part’s file name to access the 
functions for processing the individual part.  
 
 
 
 
 
 
 
 
 
 
 
Clicking on the file name in the Project Manager displays 
the related parameters in the lower part of the Project 
Manager (nesting).  
 
 
 
 
 
 
 
 
 
Using configure, the parameters for each nesting part can 
be defined. 
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10.2.2   Nesting sheet data bank 
 
In the Utils menu bar, select the Nesting line  Nesting sheet data bank. 
New material groups can be created by checking the item New sheets and clicking on this button 

. 
 

 
 
 

New subgroups can be created by checking a material group and clicking on this button . 
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10.2.3   Nesting parts 
 
In the Utils menu bar, select the Nesting module line  Sheet data base. 

 
 
Select the nesting sheet and click on this button. 
 
Paste the nesting sheet onto the plot area. If necessary, repeat the process for other nesting 
sheets.  
 
The nesting sheet can also be drawn in the shape of a geometric rectangle.  
 
Load nest list using the Utils menu bar  Nesting module or from the Project manager. 
 

 
 
 
 
 
 
To perform nesting, select the command in the Utils 
menu bar  Nesting module  Nesting, or click on 
Nest in the Project Manager. 
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The Command line contains the prompt 
 
 
Click on the nesting sheet on the plot area. If there are several nesting sheets, nesting priority is 
established according to the order in which they are selected.  

 
The prompt Select nesting sheet must be closed with ESC, once all the nesting sheets have been 
selected. 
 
The nesting parameters can then be redefined again.   

 
If the result is poor, this may be improved by reducing the Search resolution (grid in inches). The 
smaller the search resolution, the greater the optimisation time. Too small a search resolution can 
cause a system crash. 
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10.2.4   Nesting information 
 
In the Utils menu bar, select the items Nesting module  Nesting information. 
The nesting information contains information about the number of nested parts and which nesting 
sheets they are on. 

 
 

10.2.5   Calculation of areas 
 
The calculation of areas is only available from TroCAM Advanced onwards. 
 

Calculate: In the Utils menu bar, select the items calculation of areas  
 Individually or Nested. 

 
With the Individually option, different areas can be added or subtracted. In other words, parts of 
areas can be subtracted from a total area, for instance. 
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With the Nested option, the nesting-sheet area, the parts area and the residual area are displayed. 
Wastage is given in %. 
 

 
The cost calculation gives information about the parts costs and the scrap costs.  
The costs can be calculated according to area or weight. 
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11    Appendix 

11.1   Trotec IPC (Intelligent Path Control) 

11.1.1   Working Description 
IPC is a tool which takes a “HPGL” file (eg.: “input.txt”) and generates a modified new “HPGL” file 
(“eg.: “output.txt”). 
 
IPC changes velocitys and accelerations in a hpgl file and adjusts laserpowers and laser correction 
values automatically to improve performance of vector cutting and vector engraving. 
 
Benefits of IPC: 

 its possible to print a vector job with max machine speed. All velocity and acceleration 
values are changed to prepare the job for max quality and/or max speed. 

o saved time because the user need not find the optimal velocity and laser correction 
values 

o saved time because of improved job performance 
 the configuration is adjustable due xml configuration file 
 the quality and performance of very complex jobs is improved uncompareable 

 
Examples with IPC without IPC 
Arc Quality and high speed 

round oval 
Ringing 

no ringing ringing 
Laserpower on lines 

closed open 
Stuttering 

in one line stuttering 
 

11.1.2   File Description 
Following files are necessary for working: 

 latool.dll (contains functionality) 

 IPC.exe (includes latool.dll and builds interface) 

 vbpost_config.xml (contains configuration) 

 input.txt  (hpgl file) 
 
After Installation of TroCAM V10 one of the following directorys contains the IPC files and the 
postprocessors of all machines 
 
C:\LICOMDAT\MPOSTS.ALP 
C:\TROCAM\LICOMDAT\MPOSTS.ALP 
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11.1.3   Configuration 
IPC takes info from configuration file: vbpost_config.xml 
vbpost_config.xml contains acceleration values and allowed max acceleration and velocity 
changes. 
 

11.1.4   Execution of IPC for Testpurposes 
1. Take your hpgl file and rename it to “input.txt” 
2. Copy it into the IPC folder C:\LICOMDAT\MPOSTS.ALP 
3. Copy your vbpost_config.xml configuration file into the IPC folder LICOMDAT\MPOSTS.ALP 

or modify the current vbpost_config.xml file. 
4. Run IPC.exe 
5. The new file “output.txt” is beeing generated 
6. optional: check the log file “log.txt” 

 

11.1.5   Execution of IPC within TroCam 
IPC is called within visual basic postprocessor automatically. 

11.1.6   Change settings of IPC within TroCAM 

Click on the button  in the TroCAM window “Send CN to Machine” to open the “IPC 
Configuration” window. 
Refer to chapter 11.1.7   Description of vbpost_config.xml file on page 51 for further details of the 
specific values. 
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11.1.7   Description of vbpost_config.xml file 
… 
<LOOK_AHEAD_XML> 
 <ACC_TUPELS> // this files are machine dependent 
  <LA_AV0><ACC>1</ACC><T>80</T></LA_AV0> 
  <LA_AV1><ACC>1</ACC><T>60</T></LA_AV1> 
  <LA_AV2><ACC>1</ACC><T>40</T></LA_AV2> 
  <LA_AV3><ACC>1</ACC><T>20</T></LA_AV3> 
  <LA_AV4><ACC>2</ACC><T>80</T></LA_AV4> 
  <LA_AV5><ACC>2</ACC><T>60</T></LA_AV5> 
  <LA_AV6><ACC>3</ACC><T>80</T></LA_AV6> 
  <LA_AV7><ACC>3</ACC><T>60</T></LA_AV7> 
  <LA_AV8><ACC>4</ACC><T>40</T></LA_AV8> 
  <LA_AV9><ACC>4</ACC><T>40</T></LA_AV9> 
  <LA_AV10><ACC>4</ACC><T>50</T></LA_AV10> 
  <LA_AV11><ACC>10</ACC><T>50</T></LA_AV11> 
  <LA_AV12><ACC>10</ACC><T>50</T></LA_AV12> 
  <LA_AV13><ACC>10</ACC><T>50</T></LA_AV13> 
  <LA_AV14><ACC>10</ACC><T>50</T></LA_AV14> 
  <LA_AV15><ACC>10</ACC><T>50</T></LA_AV15> 
 </ACC_TUPELS> 
 
 <LA_ACC_INDICES> // this is the maximum allowed acceleration – be conservative (high values lead to very bad quality) 
  <LA_AV_MAX_X>3</LA_AV_MAX_X> 
  <LA_AV_MAX_Y>3</LA_AV_MAX_Y> 
 </LA_ACC_INDICES> 
 
 // this is the  maximum allowed velocity difference for every axis (has less influence than the maximum allowed acceleration) 
 <LA_MAX_VELOCITY_DIFFERENCE_X>5</LA_MAX_VELOCITY_DIFFERENCE_X> 
 <LA_MAX_VELOCITY_DIFFERENCE_Y>5</LA_MAX_VELOCITY_DIFFERENCE_Y> 
 
 // this rs232 values could be ignored (sending due rs232 from ipc is not used) 

<LA_OUTPUT> 
  <LA_RS232>  
   <LA_RS232_ENABLE>0</LA_RS232_ENABLE> 
   <LA_RS232_PORT>4</LA_RS232_PORT> 
   <LA_RS232_BAUDRATE>19200</LA_RS232_BAUDRATE> 
   <LA_RS232_XONXOFF>1</LA_RS232_XONXOFF> 
  </LA_RS232> 
  <LA_FILE> 
   <LA_OUTPUTDIR>"./"</LA_OUTPUTDIR> 
   <LA_FILENAME>"output.txt"</LA_FILENAME> 
  </LA_FILE> 
 </LA_OUTPUT> 
  
 <LA_START_LABEL>1</LA_START_LABEL> 
 <LA_MAX_CONNECTED_MOVES>200</LA_MAX_CONNECTED_MOVES> 
  
 // some engravers have scaled velocitys (look for fram) – machine dependent 
 <LA_ACCELERATION_SHIFT>0</LA_ACCELERATION_SHIFT> 
  
 <LA_OPTIMIZATION> 
  // use relative moves instead of absolute to save memory in machines hardware – quality is the same 
  <LA_RELATIVE_POLYGONS>1</LA_RELATIVE_POLYGONS> 
  // allow acceleration changes in output.txt vs. input.txt 
  <LA_ACCELERATION_CHANGE_ENABLE>1</LA_ACCELERATION_CHANGE_ENABLE> 
  // allow velocity changes in output.txt vs. input.txt 
  <LA_VELOCITY_CHANGE_ENABLE>1</LA_VELOCITY_CHANGE_ENABLE> 
  // could be ignored – is not used 
  <LA_CONST_VELOCITY>0</LA_CONST_VELOCITY> 
  // ipc looks for constant velocity for all contours – could be a benefit when kiss cutting 
  <LA_NO_DISCONNECT>0</LA_NO_DISCONNECT> 

<LA_CHANGE_CORRECTION_FACTOR>1</LA_CHANGE_CORRECTION_FACTOR> 
// blending is enabled when 1 – blending works only for vectors and not for circles – could be lead to velocity 
increase 
<LA_BLENDING_ENABLE blending_error="5">0</LA_BLENDING_ENABLE> 

 </LA_OPTIMIZATION> 
</LOOK_AHEAD_XML> 


